Symptom
When submit the E-Verify case the following error appears:
"E-Verify did not receive your case information. Please try to resubmit the case or try again later by going to the E-Verify To-Do tile, find the new hire, and click Start to retrigger the E-Verify case. "
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as Hiring manager
- Go to Complete E-Verify tile
- Click on start
- Submit the E-verify case. We get this error:
- "E-Verify did not receive your case information. Please try to resubmit the case or try again later by going to the E-Verify To-Do tile, find the new hire, and click Start to retrigger the E-Verify case. "
Cause
Incorrectly or missing information entered in the candidate data.
Resolution
The following details must be checked and corrected for the candidate:
- Phone number: Needs to contain only digits, no special characters allowed
- I-551 number: Should not be the number that starts with "USA".
- SSN: Starts with "999" or is blank
- SEVIS number format: Needs to be N + 10 digits, but system requires 11 digits
- State Driver's License number (BC Document Number): should contain no spaces.
- Name Format - should contain only Upper & lower case alphabetic characters, apostrophes and hyphens. Periods are not accepted although they may be part of the official name (ex: St. Pierre, Jr.)
- Date of Birth - is the person at least 15 years old? (ex: date entered as 03/06/2022) Is the date valid? (ex: date entered as 03/06/0974) – This needs to be configured with a rule in manage business configuration and cleared with EC.
- Document Receipt - is the document presented a receipt or the official document? For receipt process during Section 2 on the Form I9 the HM or Corporate Representative will select the receipt option and provide the receipt document number along with the expiration date. On the Form I9 in Section 2 the document title will have Receipt Replacement text within the document title field. Once the original document has been provided to the HM or Corporate Representative will update section 2 again with the steps to enter the original document on the Form 19 in Section 2. Once signed the Form I9 in Section 2 will now have the original document number and the Additional information section will display text stating Receipt Information updated.
Keywords
E-Verify did not receive your case information. Please try to resubmit the case or try again later by going to the E-Verify To-Do tile, find the new hire, and click Start to retrigger the E-Verify case, E-verify, Onboarding , KBA , LOD-SF-OBX-EVF , Everify , Problem
Product
Attachments
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