Symptom
Service Order cannot be created as a follow up of a contract. The following error occurs:
"Item XX: Item type Contract Service - fixed price not allowed for product ABC"
or
"Item XX: Item type Contract Service - time and material not allowed for product ABC"
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Entitlements work center.
- Select the Contracts view.
- Select Contract XYZ (XYZ represents the Contract ID).
- Click on the Follow-Up button and select Service Order.
- Go to the Services and Spare Parts tab.
- Click on the Add Row button and enter the service ABC (ABC represents the Product ID of the Service).
- The following error appears:
"Item XX: Item type Contract Service - fixed price not allowed for product ABC" (XX represents the line item number).
or
"Item XX: Item type Contract Service - time and material not allowed for product ABC"
Cause
The item maintained in the contract is an Entitlement.
Cause 1: The Entitlement in the Contract is of item type ETFC - Entitlement - fixed price.
If you create a follow up Service Order from this Contract and add a service that is maintained in the Entitled Products for the item in the contract, the Item type of this Item in the Service Order will be Contract Service – Fixed Price.
In this case you need to ensure that the following scoping question is active: Do you sell or provide services for a fixed price, but track the actual time and materials needed for reporting purposes?
Cause 2: The Entitlement in the Contract is of item type ETTM - Entitlement - time and material.
If you create a follow up Service Order from this Contract and add a service that is maintained in the Entitled Products for the item in the contract, the Item type of this Item in the Service Order will be Contract Service - time and material.
In this case you need to ensure that the following scoping question is active: Sales -> Product and Service Portfolio for Sales -> Sell Services: Do you sell services for a price based on the actual time and material needed?
Resolution
You need to activate the respective scoping question in you Business Configuration.
- Go to the Business Configuration work center.
- Select the Implementation Projects view.
- Select your implementation project and click on Edit Project Scope.
- Navigate to step 4 Questions.
- Expand the Path: Sales -> Product and Service Portfolio for Sales -> Sell Services.
- Check the following question for Entitlement - fixed price:
Do you sell or provide services for a fixed price, but track the actual time and materials needed for reporting purposes? - Check the following question for Entitlement - time and material:
Do you sell services for a price based on the actual time and material needed? - Activate your changes.
You can now create the Service Order as a follow up of the Contract and the error will not occur anymore.
Keywords
Service Order; Contract; Item Type; Scoping; Contract Service; Fixed Price; Time and Material; Entitlement; Service; Follow-Up; ETFC; ETTM , KBA , SRD-CRM-SEO , Service Orders , Problem