Symptom
Administrator Connector is throwing the "Entityinvalid.EmailAddress" error even with the input file not providing an email address.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Prepare the input file with the required fields >
- Upload the file in the correct SFTP folder >
- Run the Administrator Connector >
- After the connector runs, click "View Results" > View Details >
- The report shows the "Entity invalid.EmailAddress:" message.
Cause
It happens because the admin has an invalid email address or just a blank space set at the "Email Address" and/or "Reply To Address" fields on its record.
The issue persists even with "emailValidationEnabled=false" at System Administration > Configuration > System Configuration > LMS_ADMIN.
Resolution
- Navigate to the affected admin's record > "Summary" tab >
- Check the emails addresses set at the "Email Address" and "Reply To Address" fields >
- Update the admin's record to contain valid email addresses (that is, remove the blank space, if that's the case, or add an email address with a valid format). A valid email address can be added manually or through the input file being provided, by adding the columns concerning the email address wrongly set (EMAIL_ADDR and/or EMAIL_REPLY_ADDR) >
- Add a valid email address to the input file or a dummy one (like dummy@sap.com) if it's not required the admin to have a valid email set >
- Run the Administrator Connector >
- The admin's record should be updated accordingly.
Note: It's always recommended to engage the SAP team that delivers Professional Services or an SAP Certified Partner to review and perform adjustments in the connector configuration (KBA 2149831).
See Also
KBA 2642671 - Administrator Connector template filename and headers
Keywords
admin, administrator, connector, sf, lms, email, address, Entityinvalid.EmailAddress, administrator, entity, invalid, , KBA , LOD-SF-LMS-CON , Connectors , Problem