Symptom
When trying to change the Time profile on Job information, the following Error message comes up : "System error. Please contact administrator."
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Employee Central
Reproducing the Issue
- Navigate to the user's Job Information and change the Time profile
- The following Error message comes up : "System error. Please contact administrator."
Cause
Some of the potential causes for this Error include :
-
The existing Time Account Validity end date was manually updated via Manage data and it's not recommended to change the validity period manually in Manage Data.
-
The validity end date of the time account is 31/12/9999 although this is a recurring (flex) account. Time account validity period should not exceed more than an year for Recurring Time accounts.
- The Error is to ensure that there is data consistency on the Time account data.
Resolution
- Adjust the validity end date to one year or delete the Time account and recreate again using Time off calendar.
- If the requirement is to have a validity period till high date, then it is recommended to use permanent time accounts instead.
- Hence, it is suggested to delete the modified time account and recreate them in order to allow the New Time Profile change.
- Once this is fixed, the Time profile change should execute successfully on Job Information
Keywords
SF, EC, Success factors, Employee Central, Modify Time profile , KBA , LOD-SF-EC-TIM-JOB , Time Management in Job Info - Records & Objects , LOD-SF-EC-JOB-UI , History UI & MSS UI , Problem