SAP Knowledge Base Article - Public

3189809 - No Email Notification Received After Resetting Password in Settings

Symptom

Customer reported that no email notification has been received after resetting their password via Settings. Customer can receive email notifications when resetting passwords via Forget Password feature and via Admin Center.

Environment

SAP SuccessFactors Platform

Reproducing the Issue

  1. In the upper-right hand corner, click on your photo
  2. Settings > Password
  3. Password reset is successful but no email notification is received

Cause

Password reset via Settings is working as designed. No email notification is sent out to to users.

Resolution

For the three Forgot Password scenarios below, email notifications will only be sent to scenario 1 & 2 as per design.

Scenario #1: End-user resets password via Forget Password feature

  1. End-user clicks on “Forget Password ?” from Login Page to get into password help page.
  2. End-user provides username or email address, and clicks the reset button.
  3. An email to reset password will be sent to end-user (email subject is Password Support from XXX). In that email, there will be an encoded link to reset the password. (This link is only valid for a short period of time - 30 minutes).
  4. End-user clicks the link to access the password reset page. Our system will do the validations and then allows the user to reset the password.
  5. After resetting the password, a successful notification email (email subject is Reset Password Successful Notification) will be sent to end-user.

 

Scenario #2: Admin reset password for end-user via Admin Center

  1. As an admin, go to Admin Center -> Reset User Passwords, and reset a new password for end-user.
  2. End-user will receive an email (email subject is Your New Password from XXX). In that email there will be an encoded link to reset the password. (This link is only valid for a short period of time - 30 minutes).
  3. End-user clicks the link in the email to access the password reset page. Our system will do the validations and then allow the user to reset the password.
  4. After resetting the password, a successful notification email (email subject is Reset Password Successful Notification) will be sent to end-user.

Scenario #3. End-user resets password via Settings

  1. End-user logs in within SuccessFactors and clicks “Settings” in the top right corner. Inputs current password and new desired password.
  2. After saving, there is a message “Your password has updated successfully” on the UI.
  3. In this case, system will not send a “You have successfully updated your password” email again to user.

An enhancement request has been submitted by the customer for email notifications to also be sent for Scenario #3 - resetting password via Settings.

See Also

2088527 - How to reset user's passwords in SuccessFactors

Enhancement Request ID/URL: https://influence.sap.com/sap/ino/#/idea/281421

Keywords

no email notification, password reset , KBA , LOD-SF-PLT-PWD , Password Policy Settings & Reset Password , Product Enhancement

Product

SAP SuccessFactors platform 2111