SAP Knowledge Base Article - Public

3190632 - 'Seller' Does Not Get Selected When Sending E-Mail from Sales Document

Symptom

When sending an e-mail from a sales document's activities facet, the seller does not get determined as sender.

Environment

SAP Cloud for Customer

Reproducing the Issue

The same behaviour can be observed when sending e-mails from various sales document's activity facets. Below is an example

  1. Go to the Sales work centre
  2. Go to the (for example) Sales Quotes view 
  3. Open any Sales Quote
  4. Go to the Activities facet > E-Mail section
  5. Create a new e-mail
  6. Send. 

You expect the system to follow the logic: SalesUnit -> Employee Responsible -> Seller for the sender/ from address. However, it selected the Employee Responsible's e-mail address.

Cause

There is a difference in the manner in which the "Sender" address is calculated for Output emails (Generated emails created by using the actions against a Sales Quote) and activity emails (Where the agent decides to manually send an e-mail).

The logic "SalesUnit -> EmployeeResponsible -> Seller" is only valid for Output emails.

In case of activity emails, the preference is to set the logged in user's e-mail address as the sender.

Resolution

This is expected system behaviour.

See Also

KBA 2459235 - Sender e-mail Address of Sales Order Incorrect

Keywords

KBA , LOD-CRM-SC-EML , Email , LOD-CRM-OPP , Opportunity Management , LOD-LE-CQP-CO , Lean Sales Orders , Problem

Product

SAP Cloud for Customer core applications 2111