Symptom
You have created a Customer Invoice that did not create Intercompany Supplier Invoice.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Customer Invoicing work center.
- Go to Invoice Documents.
- Filter for All Invoice Documents.
- Search for the relevant document and open it.
- On View All navigate to Document Flow tab.
See that the Intercompany Supplier Invoice was not created.
Cause
The document has not been created because an error message that can be seen in Application and User Management work center, Process Communication Errors view filtering for Open Errors with Incidents, with the Main Error:
Product ABC not valid (ABC refers to the product ID).
Resolution
You need to finish this Product Master Data:
- Go to Product Portfolio work center.
- Go to Products view.
- Enter in the product subview (By Materials or By Services).
- Filter for All.
- Search for the relevant ID.
- Click Edit.
- In the View All navigate to Purchasing tab.
- Change the Status from Initial to In Preparation.
- Click Save.
- Change the Status from In Preparation to Active.
- Click Save.
Now your product is ready to be invoiced.
After that you can either cancel and re-create or send to support to restart the Process Communication Error.
Please note that if you cancel the document and it get stuck, you should send to support team to cancel the messages via backend as well.
Keywords
Customer Invoice. Supplier Invoice. Intercompany. Product Master Data. , KBA , SRD-SRM-SI , Supplier Invoicing , How To