SAP Knowledge Base Article - Public

3191270 - Sactisfation Survey via Workflow Rule with Business Object Account/Contact

Symptom

Error messages "Referenced object BUSINESS_PARTNER is not supported. Raise an case to Survey or concerned application team for BUSINESS_PARTNER" are thrown when creating a Workflow Rule for Sactisfation Survey with Business Object Account or Contact.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administration Workcenter.
  2. Navigate to Workflow Rules view.
  3. Open the desired Workflow Rule.
  4. Click Edit.
  5. In "Define Conditions", add placeholder #SURVEY1#.
  6. Select any Field.
  7. Error messages "Referenced object BUSINESS_PARTNER is not supported. Raise an case to Survey or concerned application team for BUSINESS_PARTNER" are thrown. 

Cause

Currently, BUSINESS_PARTNER is not enabled to send Satisfaction Survey e-mails through Workflow Rule.

Only below objects are supported.

  • APPOINTMENT_ACTIVITY
  • CAMPAIGN
  • QUOTE
  • PHONE_CALL
  • LEAD
  • OPPORTUNITY
  • SERVICE REQUEST and
  • Perfect store valuation

Resolution

This is the current expected behavior of SAP Cloud for Customer.

  1. If you are a Partner:
  2. If you are a Customer:

An alternative option may be to check the SAP Cloud for Customer Influence Site to submit an idea.

Keywords

 Survey ; Account ; Contact ; BUSINESS_PARTNER ; Error ; Workflow Rule , KBA , LOD-LE-SUR-DEF , Survey definition = design time , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions