Symptom
Error messages "Referenced object BUSINESS_PARTNER is not supported. Raise an case to Survey or concerned application team for BUSINESS_PARTNER" are thrown when creating a Workflow Rule for Sactisfation Survey with Business Object Account or Contact.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Administration Workcenter.
- Navigate to Workflow Rules view.
- Open the desired Workflow Rule.
- Click Edit.
- In "Define Conditions", add placeholder #SURVEY1#.
- Select any Field.
- Error messages "Referenced object BUSINESS_PARTNER is not supported. Raise an case to Survey or concerned application team for BUSINESS_PARTNER" are thrown.
Cause
Currently, BUSINESS_PARTNER is not enabled to send Satisfaction Survey e-mails through Workflow Rule.
Only below objects are supported.
- APPOINTMENT_ACTIVITY
- CAMPAIGN
- QUOTE
- PHONE_CALL
- LEAD
- OPPORTUNITY
- SERVICE REQUEST and
- Perfect store valuation
Resolution
This is the current expected behavior of SAP Cloud for Customer.
- If you are a Partner:
- Please use cloudsolutionpartner@sap.com or the Partnerfinder.
- If you are a Customer:
- Contact your Account Executive. Check the link https://www.sap.com/services/innovation.html#contact-us.
An alternative option may be to check the SAP Cloud for Customer Influence Site to submit an idea.
Keywords
Survey ; Account ; Contact ; BUSINESS_PARTNER ; Error ; Workflow Rule , KBA , LOD-LE-SUR-DEF , Survey definition = design time , LOD-CRM-WKF , Workflow , How To