Symptom
You see that the name of an account is changed, but when you look for the same entry in the change log, it is not shown.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales Work center
- Go to the Leads view
- Select Show all and find ABC (ABC represents the name of the lead)
- Here you see that the company name was changed from DEF (old name of the company when the lead is created) to UWV (new name of the company)
- Go to the Changes facet
Here you will see that the change from DEF to UVW is not recorded.
Cause
If a Lead ABC has an active account, any details for this account cannot be changed on the lead itself. The lead is using master data from this account. Therfore, on the lead, this data is read-only. The same is true after a conversion happens from lead to account. The newly created account is now master data and the lead consumes this as read-only.
This field is directly read from the account and changes can only be performed there. Since this is read on the go, the lead will not write this in it's change log also. The name chang can be witnessed in the change log of the correspdoing account.
Resolution
Changes made in an master data such as account are captured in the change log associated to that account and business parters.
We would not be able to change the system behavior at least in the current version.
In every release, we have implemented most of the requests coming via the “SAP Cloud for Customer” Customer Influence while submitted as an idea to meet the needs of the customer use cases based on demand
To submit an idea, please use https://influence.sap.com/sap/ino/#/campaign/1868
Alternatively , you may reach out to the SAP Customer Experience Services .Its primary goal is to help our clients create their own connected customer experience relying on a suite of SAP Cloud solutions. It acts as a trusted advisor in all stages of their project lifecycle: from early planning through project realization, all the way to reaching full productivity with our solutions
You can connect them by mailing at sapcx-services@sap.com.
Keywords
Lead, Account , Change Log, Not found , KBA , LOD-CRM-LM , Lead Management , LOD-CRM-ACC , Account , LOD-LE-BP-BP , Business Partner , Problem