Symptom
The processing of termination end handling events is delayed (up to 3 hours) when termination / scheduled date on the time management task is in the past.
Reproducing the Issue
- Enable Termination End Handling Configuration Object
- Terminate a user with a date in the past (with offset in days considered, the Scheduled Date is still in the past)
- The Time Management Task of event type "termination end handling" stays as "To be processed" for up to 3 hours, although "Execute on save" is set to Yes and scheduled date is in the past
Cause
There are multiple events created from Time Management and we set the next one to "delayed" if the previous event execution is still not finished/completed.
Resolution
Our Engineering team are working on an improved processing logic here for termination end handling events when the scheduled date is in the past. This KBA will be updated when the details and fix date are confirmed.
As a workaround, please manually update the Time Management Task object for the user and set the field "Execute on save" to "No" , save it and then set it back to "Yes" and save. The task should then get executed".
Keywords
TIM-28045, time management task stuck, event is not picked up, event stays in to be processed status, termination end handling is not triggered , KBA , LOD-SF-EC-TIM-TA , Time Accounts (TAT, TA, TAD) , LOD-SF-EC-TIM-CAL , Calendar Jobs , Bug Filed