Symptom
You split delivery with SOAP API Split Outbound Delivery – Receive from Warehouse (B2B) (SplitOutboundDelivery_In), the new delivery is created successfully but you are unable to find the message with the new delivery number at APP "Message Dashboard".
Environment
SAP S/4HANA Cloud System all version
Reproducing the Issue
- The URL can be like https://XXXX.s4hana.ondemand.com/sap/bc/srt/scs/sap/SplitOutboundDelivery_In?MessageId=916C6E5X-3BB2-11CA-A054-08002B1BB6K9
- The payload can be like:
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:pm="http://www.getpostman.com/">
<soapenv:Header></soapenv:Header>
<soapenv:Body>
<n0:SplitOutboundDelivery xmlns:n0="http://sap.com/xi/EDI/DECWMS">
<MessageHeader>
<CreationDateTime>YYYY-MM-DDT00:00:00.1234567Z</CreationDateTime>
<SenderBusinessSystemID>MYSYSCLNT</SenderBusinessSystemID>
</MessageHeader>
<Delivery>
<OriginalDeliveryDocument>80000001</OriginalDeliveryDocument>
<NewDeliveryDocument></NewDeliveryDocument>
<DeliveryItem>
<DeliveryDocumentItem>000010</DeliveryDocumentItem>
<ActualDeliveryQuantity unitCode="PCE">2</ActualDeliveryQuantity>
<ActualDeliveredQtyInBaseUnit unitCode="PCE">2</ActualDeliveredQtyInBaseUnit>
<DeliveryToBaseQuantityDnmntr>1</DeliveryToBaseQuantityDnmntr>
<DeliveryToBaseQuantityNmrtr>1</DeliveryToBaseQuantityNmrtr>
<Serial>
<SerialNumber>10000001</SerialNumber>
</Serial>
<Serial>
<SerialNumber>10000002</SerialNumber>
</Serial>
</DeliveryItem>
</Delivery>
</n0:SplitOutboundDelivery>
</soapenv:Body>
</soapenv:Envelope>
Cause
This is intended that you are unable find the new delivery number at APP Message Dashboard.
The split message can optionally contain a number for the new delivery. This new delivery number must be set according to the external number range of the delivery type in the SAP S/4HANA Cloud system. Conflicts of the delivery number should be avoided by organizational means. Otherwise, the split message remains in an error status in the message dashboard of the S/4HANA Cloud system and Split Outbound Delivery Confirmation message returns an error to the sender.
If the split message does not contain a number for the new delivery, the SAP S/4HANA Cloud system assigns a new number automatically.
There is no message is sent out when the delivery number is assigned at SAP S/4HANA Cloud system.
Resolution
Please refer the Original Delivery Document number.
Keywords
SOAP API, Split Outbound Delivery – Receive from Warehouse (B2B), SplitOutboundDelivery_In, Delivery number, Message Dashboard, /LE3PL, 3PLSPLTOBD, Split Outbound Delivery Inbound, /AIF/ERR, Srt_moni , KBA , LE-IDW-CEN-2CL , Central Processing (Public Cloud) , LE-SHP-API , Interfaces for Delivery Documents (API) , How To