SAP Knowledge Base Article - Public

3193151 - Custom Email with Filter Business Rules does not Trigger - Onboarding

Symptom

  • Custom welcome email are not being sent to onboardees using filter business rules.
  • Custom email using custom email category and trigger with Filter business rule are not working.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Initiate onboarding for candidate.
  2. Make sure the filter condition in the business rules is satisfied.
  3. Complete the New Hire Data Review step
  4. Check the email status in Email Services.
  5. See that the Custom Email did not trigger.

Cause

This is expected behavior if you are using a custom category and trigger in email sevices for onboarding.

Resolution

As per the Implementation Guide - Configuring Email Categories- SAP Help Portal, Email Services in Onboarding allows you to create an email category.

RESTRICTION:

However, the application of new email categories to the notification process is not supported.

At present, this is not yet part of the Road Maps for Onboarding.

See Also

Configuring Email Triggers - SAP Help Portal

Keywords

Email Services, Custom Email, Custom Trigger, Custom Category, ONB, Onboarding, Onboarding 2.0, ONB 2.0 , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding 2111