SAP Knowledge Base Article - Public

3193167 - Message 'Deletion in progress. Please wait a moment, then refresh the list' Appears when Using Initiate Deletion of Lead But Lead is Not Deleted

Symptom

You are trying to delete a Lead using the Initiate Deletion option available in Lead OWL. Message appears 'Deletion in progress. Please wait a moment, then refresh the list' but lead remains there even after several refresh attempts.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Open the Leads work center view.
  3. Select Lead ABC (where ABC is the ID of a Lead that can be deleted).
  4. Click in the More button and select the Initiate Deletion option.
  5. Message 'Deletion in progress. Please wait a moment, then refresh the list' appears.
  6. Click in the refresh icon.
  7. Lead ABC still appears in the list.

Cause

1) If you open the lead ABC, you can see in the header the mandatory field Customer Last Name is missing and/or other mandatory field values empty.

OR

2) A PDI (custom code) validation is hindering lead deletion.

Further, please note:

  • Leads with status "Open" can be deleted if there is no follow-up data or conversion. 
  • Option "initiate deletion" would be greyed out for leads that are converted.

Resolution

 For point 1)

  1. Open the Sales work center.
  2. Open the Leads work center view.
  3. Open Lead ABC (where ABC is the ID of the lead).
  4. Fill in all mandatory fields in lead header.
  5. Click in the save button and try using the Initiate Deletion feature once again.

For point 2)

  1. Go to the Administrator work center.
  2. Open the Background Jobs work center view.
  3. Select the 'All Jobs run in the last Week' query.
  4. Select DEF (where DEF is the most recent entry of Run Type as 'Data Destruction Run' and Description as 'Deletion of Marketing Leads').
  5. Click in the View Application Log button in the upper right corner of OWL.
  6. Select the Results view.
  7. Expand the entries in line 'Workpackage execution ended with error(s)'.
  8. Notice the entry 'Save rejected by validation (Solution GHI)'.
  9. Seek the responsible peers for the GHI custom solution and ask for clarifications.

See Also

 2646592 - It is not Possible to Delete the Lead

Keywords

'Deletion in progress. Please wait a moment, then refresh the list ; Initiate Deletion ; Deleted ; Remains ; Lead ; Background Job ; , KBA , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions