Symptom
The sales order line item is a service item, service confirmation of this service item line was cancelled. You want to cancel this line afterwards, but the Reason For Rejection field is still read only on the line, hence you are not able to cancel this serivce item line.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Open the sales order ABC and go to Items tab. (ABC represents the ID of the sales order)
- Select line 10, the delivery status is In Process, Reason For Rejection field is read only mode.
Cause
Before cancelling the service confirmation of the service line, you had maintained the reason for rejection on header (in General tab). So the Reason for Rejection field on the item level became read only.
Even you cancelled the service confiramtion of this service item line, the fields is not resopen.
Resolution
Remove the reason for rejection on header, this will update the item level reason for rejection and make the field open again.
Then maintain the reason for rejection on header or item level, the sales order is then cancelled.
Keywords
reason for rejection; read only; grayed out; sales order; service item , KBA , AP-SLO-SO , Sales Order , Problem