Symptom
In advance search on Task OWL screen, you have the "Exclude Tasks Associated with Visits" check box.
However, this check box does not appear to give the desired results: it is not filtering for "Exclude Tasks Associated with Visits" as expected.
This means: there is no change in the ticket count after the search execution, even after checking this check box.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log into C4C system;
- Go to activities WC;
- Go to Tasks view;
- Select "All" query;
- Go to advanced search
- Look for check box "Exclude Tasks Associated with Visits";
- Select the checkbox and press "go";
You will see that there is no change in the ticket count after the search execution, even after checking this check box.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Cause
Development have checked and here is the explanation: "Exclude Tasks Associated with Visits" - displays the Tasks excluded which are determined by activity planner/activity worklist item. The tasks which are added manually to visits are not excluded.
If the task is not associated with any activity_worklist_item, then this is visible in the result list on the Task OWL.
This is the current system behavior and cannot be changed.
Resolution
This is the current system expected behavior.
An alternative option may be to check the SAP Cloud for Customer Customer Influence to submit an idea
Keywords
system behavior; Exclude Tasks Associated with Visits; check box; filter; advanced search; , KBA , LOD-CRM-ACT , Activities , Known Error