Symptom
When trying to open the Payment information portlet for edit through Employee Profile, an error is displayed: Sorry, it is not possible to maintain payment information if there is no job information or no country/region in job information.
This is only happens with the ONB external users post MPH step. The employees who are not coming from ONB is working fine.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as admin
- Go to "My Employee File" in the home drop down
- Click on User search and make sure "include inactive users in search" is ticked
- Search for candidate and open the employee record
- Go to "Bank Details" portlet and click on the history icon to see the change history
- Click on any of the event dates and click on edit
- After clicking edit, error comes as "Sorry, it is not possible to maintain payment information if there is no job information or no country/region in job information."
Cause
The error shows up as the job information record is not visible for onboarding candidates prior to the start date. If you scroll to job information, you will see that there is no record displayed on the UI as there is no active job. If you click on view history/changes, you can see the job information record. As there is no active job info on UI, this error is displayed in bank details portlet.
Resolution
This is expected system behavior. You can check with any active candidate from onboarding, the issue will no longer be there as there will be an active record of job info. For inactive candidates, there will be an error presented while modifying bank details as it is dependent on job country.
However, this error does not block you from making changes to the bank details.
See Also
Keywords
bank, onboarding, error, payment information, manage pending hires, Sorry, it is not possible to maintain payment information if there is no job information or no country/region in job information. , KBA , LOD-SF-OBX-EC , Integration EC - MPH, Hire , Problem