Symptom
The homepage bell notification is showing inconsistent date format for notifications.
See below sample notifications:
DDMMYYYY
MMDDYYYY
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Login to customer's instance
- Check the Bell Notification
Notifications will show inconsistent date format for different notifications. Some have DDMMYYYY and some have MMDDYYYY.
Cause
As per engineering team's investigation, the reason being why the notification date formats are not consistent is because of that those transactions are being made by multiple people having different locale parameter settings.
The date format seen in the bell notification bar is as per the user who initiated the transaction (meaning, who did the actual update say manager change or actual hire) and not by the format of the user viewing those notifications.
Resolution
To have a consistent date format for notifications in the homepage bell notification bar, the local parameter settings of the user who will initiat the transaction (meaning, who did the actual update say manager change or actual hire) should all have the same date format.
See Also
Keywords
date format, bell notifications, DDMMYYYY, MMDDYYYY, incorrect format, incorrect notification, wrong date format, notifications , KBA , LOD-SF-PLT-LHOM , Latest Home Page , How To