Symptom
1. You are using SOAP API OrderRequest_In to create a sales order and you are receiving an error message in Message Dashboard app: Entity SLINE is not available
2. The product provided in the request within the payload is available in Manage Customer Materials app.
3. The product in the payload has lowercase characters, for example: <BuyerProductID>X-PF-100-1610x675</BuyerProductID>, while in the Manage Customer Materials app the customer material is X-PF-100-1610X675, which are all in uppercase.
Environment
SAP S/4HANA Cloud
Cause
This error is due to the reason that the material cannot be recognized in the supplier's system.
This error will not happen in the E2E scenario, because both in the purchase order and in the sales order, when saving the document, the system will automatically convert all field into uppercase.
When you are using a third party tool like postman/swagger to pass payload with field <BuyerProductID> in lowercase, the EDI won’t convert the field to uppercase.
Resolution
By SAP design, the field <BuyerProductID> is not case-sensitive.
When you create a customer material in Manage Customer Materials or create a sales order in supplier's system, or purchase order in the buyer's system, the system will automatically convert this field to uppercase.
In cases where a third-party tool is used to send OrderRequest_In to create a sales order, it must be ensured that the <BuyerProductID> field contains the value of the product ID in uppercase.
See Also
Keywords
2EL, B2B, SOAP API, EDI, BuyerProductID, F2499, upper case, lower case, uppercase, lowercase, customer material, product, OrderRequest_In, end-to-end, e2e, end-2-end , KBA , SD-SLS-EDI , S/4HANA: Sales EDI Messages , SD-SLS-EDI-2CL , S/4HANA: Sales EDI Messages (Public Cloud) , SD-MD-AM-CMI , Customer-Material Information , SD-SLS-API , API , How To