SAP Knowledge Base Article - Preview

3195178 - Upgraded to RS 16.0 SP03 PL10 and SSL will no longer work - SRS

Symptom

There are several clues to the SSL not working:

  • The repserver log shows one warning, but no errors:
    ...
    'FIPS is 0 in CCL library.'
    (-1): key pair create succeed!.
    (-1): crypto context create succeed!.
    Reading '/work2/ase16/repserver/da_repserver.cfg' for configuration information.
    Using config file encrypted password for the RSSD primary user.
    Using config file encrypted maintenance password for the RSSD maint user.
    Using config file encrypted password for the ID user.
    ...

  • SSL protocol value is set to 'TLSv1'.
    Use SSL service is set to 'on'.
    Default for connection ha_failover is set to 'on',
    Default directory service provider is: 'InterfacesDriver'.
    WARNING #31327 GLOBAL RS(GLOBAL RS) - ic/encrypt/enc_ccl.c(1655)
     Found no entry 'RS_random' in config file.
    ...

  • When using isql - it returns:
    CT-LIBRARY error:
            ct_connect(): directory service layer: internal directory control layer error: Requested server name not found.
  • It was working in RepServer 16.0 SP03 PL07
  • The only thing that changed was upgrading to PL10


Read more...

Environment

SAP Replication Server  (SRS) 16.0 SP03 PL10

Product

SAP Adaptive Server Enterprise SDK 16.0 ; SAP Replication Server 16.0

Keywords

KBA , BC-SYB-REP , Sybase Replication Server (standalone) , BC-SYB-SDK , SDK , Known Error

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.