SAP Knowledge Base Article - Public

3195204 - Unable to migrate to new DocuSign authentication method - Recruiting Management

Symptom

When trying to update to the new DocuSign authentication method for the b2205 release, the system throws an error: 

Fetch couldn't retrieve your DocuSign information. Log in to DocuSign and go to your My Apps & Keys page to copy your User ID and API Account ID information, then paste them here.
To enable eSignature, DocuSign credentials are mandatory

Environment

  • SAP SuccessFactors Recruiting Management
  • DocuSign

Cause

This is happening because there is also a change in the type of Third-Party eSignature Environment, but the legacy credentials for the previously selected information are still there.

Resolution

If you are trying to switch the Third-Party eSignature Environment value from Production to Demo or vice-versa, before migrating to the new authentication method, you must change the legacy authentication values first, save it, then add the new authentication User ID an Account ID.

Keywords

api, docusign, docu, sign, offer, letter, e, signature, esignature, third, party, 3rd, credentials, authentication, login, manage, recruiting, settings, rcm, approval.
, KBA , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions