SAP Knowledge Base Article - Public

3195450 - Error When Activating DocuSign Account - Onboarding

Symptom

  • Unable to successfully activate DocuSign account
  • Error is received when DocuSign account is attempted to activate in SuccessFactors

Error: Failed to get access token for OAuth flow: consent_required - Envelope could not be sent to DocuSign because the consent for SAP SuccessFactors has been revoked. Please reactivate DocuSign in Configure DocuSign eSignature.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Go to Configure DocuSign eSignature
  2. Enter account details for DocuSign
  3. Click on Activate
  4. Error is later received.

Cause

Permission for SAP SuccessFactors access to DocuSign account has not been granted.

Resolution

When activating the DocuSign account in Configure DocuSign eSignature, access must be granted in the DocuSign side in order for account to properly sync. When activating the DocuSign account in SuccessFactors, please access DocuSign account and select the "Allow Access" option when prompted for SAP SuccessFactors access. 

Please note that message at the DocuSign side prompting for permission to allow access may look like the image below:

Keywords

SF, success factors, ONB, OBD, OBX, on boarding , KBA , LOD-SF-OBX-DSN , Docusign Integration , Problem

Product

SAP SuccessFactors Onboarding all versions

Attachments

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