Symptom
When you navigate to Accounts and when you open the Recommendation View it is blank.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers work center.
- Go to the Accounts view.
- Click the light bulb icon at the top right corner.
- Observe: the Recommendation view is blank.
Cause
Scenario 1: You have not followed the procedure to configure the Index Influencers in the Customer Insights Administration. The user ID is missing.
Scenario 2: The fiscal period is not maintained for next quarter.
Scenario 3: The machine learning is not enabled for lead or opportunity.
Resolution
Scenario 1: Please maintain the user ID with the steps below.
- Go to the Administrator work center.
- Go to the Customer Insights Administration view.
- Select Index Influencers.
- It is important to also click Reset to Default to be able to edit
- Enter the user ID (the user ID is used to make the OData API calls and the user must have access to Leads via OData).
- Click Save.
- Wait for a few minutes - this could take up to 8 min.
- Repeat the steps used above for reproducing the issue.
Scenario 2:Please maintain fiscal period for next quarter.
- Go to Business Configuration work center.
- Go to Implementation Projects View.
- Select the current Project and click on Edit Project Scope.
- Go to step 4 Questions.
- Expand the node Built-in Service and Support and System Management.
- Choose Analytics.
- In the right pane the last question will be "Enable Reporting on Fiscal Year?".
- Scope this question "Enable Reporting on Fiscal Year?".
- Click Next and then Finish
- Go back to Business Configuration -> Implementation Projects View.
- Select the current project and navigate to Open Activity List -> Fine Tune -> Enable Reporting on Fiscal Year.
- Configure and activate the desired fiscal year variant.
- This fiscal year variant should be Active.
- The "Default Fiscal Year variant" needs to be selected.
- All details need to be maintained for fiscal quarter.
- Click Save
Scenario 3:
- If you would like to enable Deal Intelligence(Opportunity Scoring) and Leads Intelligence and you have the license, please kindly create a new case with a request for the activation. For more information, please kindly refer to the help documentation - Machine Learning Scenarios in Cloud for Sales
- If you don't want to enable Deal Intelligence(Opportunity Scoring) and Leads Intelligence, please adjust the weightage to 0 with the below steps.
- Go to the Administrator work center.
- Go to the Customer Insights Administration view.
- Select Index Influencers.
- For Customer Relationship Index
- Set Lead Score Threshold and Opportunity Score Threshold to 0
- Click Save
- Click Customer Health Index
- Set Lead Score Threshold and Opportunity Score Threshold to 0
- Click Save
Keywords
Index Influencers, Customer Insights Administration, Accounts, ODATA API,RI,Relationship Intelligence,Sales addon,Sales add-on,Recommendation View,blank,empty
, KBA , LOD-CRM-SBS-360 , Customer 360 Profile , How To