SAP Knowledge Base Article - Public

3196003 - Contract Scheduled Invoice Requests Not Created According to the Time Frame

Symptom

Customer Contract just generates 2 Invoice Schedule and you were expecting to generate invoice time frame from e.g. 01.01.2022 until 01.12.2026.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work Center.
  2. Go to the Contracts view.
  3. Open Contract AAA (Where AAA represents the Contract ID).
  4. Navigate to the Pricing and Invoicing tab and then the Invoice Schedule subtab.
  5. Expand all Items:
  • Items XX  -  has first invoice date on e.g. 01.01.2022 and the last one on 01.12.2026
  1. Go to the Customer Invoicing work center.
  2. Open the Invoice Requests view.
  3. Search for Contract ID AAA.

You can see a Scheduled Invoice Request dated has two Invoice Request created.

Cause

When an invoice schedule is created, it is created for the dates within the item validity only. Therefore, we would expect for item XX that there are invoice schedule dates up to 01.01.2022 only, even though the end date of 01.12.2026 is maintained in the invoicing timeframe (recurrence pattern).

However, in this case, there are only two invoice schedule dates for item XX (covering the period of 01.01.2022 - 28.02.2022). This is because at the time the invoice schedule was created, the validity end date of item 10 was 28.02.2022. Then it was changed the end date of item 10 from 28.02.2022 to 30.04.2022.

Resolution

To update the invoice schedule, you would have needed to manually update the invoice schedule by deselecting item XX for the relevant recurrence pattern in "Edit Invoicing Timeframe", and then applying it again.

Keywords

recurrence pattern; Contract; Invoice Request;  Invoice Schedule , KBA , SRD-CRM-ORD , Orders & Contracts , How To

Product

SAP Business ByDesign all versions