Symptom
This knowledge article outlines investigation and troubleshooting steps for issues encountered when initiating a candidate’s onboarding from the Recruiting module.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding
Cause
Possible cause(s):
- The primary email address already exists in the system.
- Mandatory fields were not completed before initiating onboarding.
- The picklist for Email/Phone type is not properly configured.
- Start Date, Manager, and Company are not mapped in Admin Center > Recruit-to-Hire Data Mapping.
Resolution
To start the onboarding process flow, initiate onboarding for the candidate. This can be done for one or multiple applications within a single job requisition.
Prerequisites:
- BizX Onboarding Integration. In Provisioning, go to Company Settings Recruiting Enable Onboarding Integration.
- Setup Onboarding Integration: Go to Admin Center, in the Tools Search field, enter Onboarding Integration Setup. The settings tab allows you to enable Onboarding for either all Job Requisitions, or only certain Requisitions. You can use the provided dropdown menu to set criteria for the requisitions which have Onboarding applied. For more information, scroll down to see Settings for Onboarding Integration Setup in the Related Links section.
- Onboarding Initiate Permission role-based permission in Manage Permission Roles Recruiting Permissions.
- Grant feature permissions for Onboarding in the Application XML. For more information on feature permissions, scroll down to see feature-permission Elements in the Related Links section.
At this stage, the SAP_ONB2_ PreDay1AccessCheck rule, which is set to "True" by default, is used to evaluate whether Onboarding process should start. You can apply your business criteria on any of the Employee Central entities like Country, Department, Division, and Job Code to evaluate this rule.
Configuration Steps:
- What is the Procedure to Initiate Onboarding Process from Recruiting
- Validating the Exception Data in the Onboarding Process
Troubleshooting Steps:
Q1: Candidate initiated with "Success" status from RCM but is not visible in the Onboarding Dashboard
Answer:
Scenario 1: How to check if the candidates Process Initiation Record is successfully created
--> With the below mentioned steps we will be able to identify why the candidates Process Creation has failed.
-
Check Splunk Log using the following Case Files: <Company Id> "Create Process Initiation Record" "primaryEmail=abc@abc.com" (PrimaryEmail is the candidates email id used at the time of onboarding initiation)
- Check the thread Id to identify what is the error message.
Scenario 2: How to check if the candidates External User Profile is created successfully
--> With the below mentioned steps we will be able to identify why the candidates External Profile Creation has failed despite the candidates Onboarding Process Id created. This is usually caused due to incorrect/insufficient information passed from RCM to ONB. For example, if there are any mandatory fields mapped in Recruit to Hire Data Mapping but this data is not passed from RCM to ONB.
-
Check Splunk Log using the following Case Files: <Company Id> "Create External User and ONB objects" "primaryEmail=abc@abc.com" (PrimaryEmail is the candidates email id used at the time of onboarding initiation)
- Check the thread Id to identify what is the error message.
Scenario 3: How to check if the candidates HRIS Data is saved successfully
--> With the below mentioned steps we will be able to identify why the candidates HRIS Data Save has failed despite the candidates External User Profile being created. This is usually caused due to UserId creation failed or similar issues.
-
Check Splunk Log using the following Case Files: <Company Id> "Save HRIS Data For User" "primaryEmail=abc@abc.com" (PrimaryEmail is the candidates email id used at the time of onboarding initiation)
- Check the thread Id to identify what is the error message.
Scenario 4: Phone/Email type issue
As per the Analysis done via the jira OBX-23702
Data issue will happen when either Phone Type and/or Email Type has picklist entry with external code in either Lower Case or Mixed Case. Currently, HRIS Save can only process Upper Case External Code entries. Other values will lead to null string in DB.
Please correct the picklist entries that are defined with Lower Case. As we store picklist option id in database, changing external code is backward compatible. In the below example we can see that the external code is in lower case, this will cause data issue. The External code should be in Upper Case.
Note: While changing we need to make sure both External Code and Non-Unique External Code are updated to Upper Case
Q2: When trying to initiate onboarding there is an error that says: We were unable to initiate the onboarding process because the values for the following fields are missing or not mapped: [Start Date - (not mapped), Recruiting Manager - (not mapped), Company - (not mapped)].
Answer:
Scenario 1:
In Recruit to Hire Data Mapping, under "Mandatory Onboarding HRIS Elements" all the fields under employmentInfo, jobInfo and personalInfo should be mapped and the value should be passed from RCM to ONB.
Additional Information: Checking the Values Passed from Recruiting to Onboarding
Scenario 2:
- In the Edit Applicant Status Configuration, under Onboarding, there is no Hired Flag set for Hireable or Hire Status
- Hireable Options are settings used to configure Recruiting Management Central-Employee Central integration.
- When an applicant is placed into a "Hired" category status, the number of openings field subtracts an opening and the candidate is added to the list to be converted in the External to Internal Candidate Conversion job. Every applicant status set should include at least one status in the "Hired" option.
- This behavior applies to all applicants in In-Progress, Onboard, and Hired statuses in the current requisition which do not have the option "Hired".
- Only applicants in a status marked as options "Hired" will be kept in their current status.
See Also
KBA:
- 3066608 - [Onboarding] Candidates do not appear in onboarding dashboard after initiation from RCM (Onboarding/Offboarding)
- 3064169 - [Onboarding] Candidates do not appear in onboarding dashboard after initiation from RCM
- 3194225 - [Onboarding] Candidate not visible in ONB after initiation from RCM - Unfinished process in BPE
- 3100486 - Error - After initiating onboarding from RCM, Candidates are not appearing in onboarding dashboard - Onboarding
- 2978334 - Unable to initiate the Onboarding Error: We were unable to initiate this onboarding process (2.0) because the values for the following fields are missing or not mapped: [<Fields affected>]
Implementation Guide Link:
PDC:
Keywords
onboarding, initiate, recruiting, candidate, main, kba, initiation, email, phone, type, manager, start, date, company, picklist, mandatory, fields, missing, not, available , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem
SAP Knowledge Base Article - Public