Symptom
You notice that there is no data in the Approval Process tab of a Sales Order. Instead the following notification is displayed:
An approver could not be determined. Either approval is not relevant or the task is unassigned. Please contact your system administrator.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Open Sales Order XYZ (XYZ represents the Sales Order ID).
- Navigate to the Approval Process tab.
- There is no Approver assigned an the following notification is displayed:
An approver could not be determined. Either approval is not relevant or the task is unassigned. Please contact your system administrator.
Cause
This can have the following Reason:
- The Approval Status of the Sales Order is not In Approval
- The Approval Task cannot be assigned to an Employee
The Approval Status, Approver and Phone Number is only available in this tab if the Sales Order is in status In Approval, the Approval Task is assigned to an Employee and the Approval Task is not Completed or Cancelled.
Details of the Approval Status and Approver will only displayed in this tab if there is an open Approval Task that is assigned (automatically by the system or manually) to an Employee.
This means that, if the Approval Task is approved, the Approval is withdrawn or the Approval Task was sent back into Revision the previous entries in the Approval Process tab will be removed.
Resolution
This is the expected System behavior.
You can check if the Approval Task is unassigned as follows:
- Go to the Application and User Management work center.
- Select the Business Task Management view.
- In the Drop Down List select Unassigned Items.
- Here you will find all Business Tasks which could not be assigned.
- Select the respective Approval Task for Sales Order XYZ and check in the Application log why the Task could not be assigned.
- Solve the respective issue and the click on Determine Assignment. (See also KBA’s in the section Additional Information)
- Or you can manually assign the task to a valid user via the Actions button and the Assign Items option.
Once this is done, the respective details will be visible in the Sales Order and the Approval Process tab.
See Also
KBA 1831750 - The Approval Task For The Sales Order Remains Unassigned
KBA 2807601 - Sales Order Approval Notifications are not Sent for the Approver.
KBA 2694432 - Task "No approver found; task is unassigned" on Contract or Sales Document
KBA 3047480 - Revision Action is Not Visible in Approval Process Tab
Keywords
Approval; BTM Task; Approval Task; Approver; Sales Order; Approval Process; No Data; missing , KBA , AP-SLO-SO , Sales Order , Problem