Symptom
When importing CFONB bank statement file in 'Manage Incoming Payment Files' app, error 'No balance item exists; file has not been imported' appears.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to "Manage incoming payment files" app.
- Upload a CFONB bank statement file.
Cause
Bank delivered statement files without end of line indicators; hence system can only recognize the first record (Opening balance). The program is unable to interpret the rest of the information. Every record must be stored in a separate line in the files to be imported.
Resolution
There are three possible solutions:
- Check with bank to provide the bank statement file with CR/LF. --> SAP Recommended Solution.
- Manually edit the file with notepad by pressing enter.
- Create a pre-processing program using your third-party service providers to get the file adapted.
See Also
Definition of CR/LF:
CR = Carriage Return - moves the cursor to the beginning of the line without advancing to the next line.
LF = Line Feed - moves the cursor down to the next line without returning to the beginning of the line.
Keywords
CFONB, Manage incoming payment files, no balance item, bank statement, S/4HANA Cloud, CR/LF, F1680 , KBA , FI-AP-AP-B1 , Payment transfer (w/o DE, US) , FI-BL-PT-BA , bank statement , Problem