SAP Knowledge Base Article - Public

3197571 - KUT Sorting Of Products List Not Working In Sales Order

Symptom

You have created a sorting for the products list using Key User Tools. When you end adaptation, you notice that the sorting is not respected.

Environment

 SAP Cloud For Customer

Reproducing the Issue

  1.  Start Adaptation Mode.
  2. Navigate to Sales Workcenter -> Sales Orders View -> Open Any Sales Order.
  3. Highlight the Products List in the Overview and in adaptation panel, click "Sort and Group By".
  4. Choose the field and order and click apply, and then end adaptation mode.
  5. You notice that however the list is not sorted as expected.

Cause

There is two Products Lists in the Sales Orders TI. One in the Overview Facet and one in the Products Facet. Both the lists are bound to "/Root/Item". So the table is only read and loaded once on the UI.

Resolution

To be able to sort the lists as expected, both lists need to be set as the same in the Overview facet and the Products facet.

Keywords

Sort, Sorting, Order, List, Table, KUT, Adapt, Adaptation, Set, Change, Configure, Product, Products , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions