Symptom
When there are multiple take rules associated with a time type and more than 1 error message is triggered for a time off request, can the order in which these messages appear be changed?
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central : Time Off
Reproducing the Issue
- Assign multiple take rules to a time type:
- Create a time off request in such a way that these rules get triggered:
- The messages do not appear in the order of the take rules assigned to the time type
Cause
The messages do not appear in the order of the take rules assigned to the time type because during execution, the system loops over the take rule group as a whole and does not consider the order in which these rules are added to the time type.
Resolution
- Currently, it is not possible to change the order in which the messages appear when applying for a time off request
- If you would like to have this feature, please raise an enhancement request for the same: https://launchpad.support.sap.com/#/notes/2090228
Keywords
Take Rule, order of execution, sorting, sequence, order, message, time off, employee central , KBA , LOD-SF-EC-TIM-UI , Team Absence Calender/ Workbench/ ESS UI's , Product Enhancement
Product
Attachments
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