SAP Knowledge Base Article - Public

3197768 - Background jobs cancelled - Failed to close application log

Symptom

Custom MDR jobs getting cancelled with errors stating 'Cancelled manually or by the system'

Environment

SAP Cloud for Customer

SAP Business ByDesign

SAP Cloud Application Studio

Reproducing the Issue

  1. In your cloud solution, open background jobs and filter by failed jobs.
  2. Open jobs with status 'Cancelled manually or by the system'
  3. Search for erros in such as 'Error called FPP service CLOSE; Action failed' or 'Execution of CLOSE action of BO ApplicationLog failed'
  4. This indicates there is a highloiad of the Applicaiton Log BO due a large number of warnings for example

Cause

A setting in custom MDR configurations in your Cloud Studio may be allowing warning messages to be shown. If these exceed many thousands the Application Log BO can become overwhelmed and cause background jobs to fail.

Resolution

  1. Adjust seetings of the related .RUN file in your Cloud Application Studio
  2. open XXXXXX.run -> Control Parameters tab -> Detail Level
  3. Select Errors rather than 'All details' or 'Errors and Warnings' - as per screen shot below

AppLog.jpg

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Keywords

Application BO; MDR; background jobs; Failed MDR; AP-RC-APL; , KBA , AP-RC-BDS-MDR , ByDesign Studio Mass Data Run , Problem

Product

SAP Cloud for Customer core applications 2202