Symptom
Employee is unable to edit National ID information as system is generating the error "You do not have permission to edit the value. Please contact your system administrator" even though ESS permission is enabled to edit/correct National ID Information.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to Employee Profile;
- Scroll down to National ID Information portlet;
- Try to edit the existing National ID or add a new one > hit save;
- Error appears.
Cause
Position Management is enabled in Manage Employee Central Settings even though it was not implemented
or
The Regular Expression is configured for the field to has a certain number of characters and you're inserting more or less.
Resolution
Disable Position Management settings as per below:
a. Go to Manage Employee Central Settings;
b. In the Others section, switch Position Management to Off.
or
Check the length configured for the National ID and then insert the respective number of characters within the field in Employee Profile.
To check the length, go to Manage Business Configuration > nationalIdCard > choose the National ID of the country you want > Check the Regular Expression.
Please also refer to the Guide Country/Region Specifics in Employee Central | SAP Help Portal and to the KBA 2526193 - Manage Business Configuration: How to Create or Edit National ID Card formats in BCUI to check if the configuration is correctly made.
See Also
Keywords
national id, national id card, national id information, position, position org chart, manage business configuration, bcui, portlet, national id portlet, regular expression, you do not have permission to edit the value. Please contact your system administrator, successfactors, employee profile, employee central , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , LOD-SF-EC-POS , Position Management , Problem