SAP Knowledge Base Article - Public

3198458 - Business Partner relationships not replicated from SAP Cloud for Customer to SAP Marketing Cloud

Symptom

When replicating business partner relationships from C4C to Marketing Cloud via iflow "Replicate Business Partner Relationship to SAP Marketing via Business Partner Web Services", you see that the iflow is completed in the SAP CPI message monitoring, but there is no successful record in the Marketing dashboard. The relationship is not updated in SAP Marketing cloud as not data was received from CPI.

Environment

SAP Marketing Cloud

SAP Cloud for Customer

SAP Cloud Platform Integration

Cause

The CPI artifact "Value Mapping for SAP Cloud for Customer and SAP Marketing Integration" has not been deployed, which makes the C4C BP relationship outbound message being filtered.

Resolution

You should maintain the Mapping of Business Partner Roles between SAP Marketing Cloud and SAP Cloud for Customer in the CPI artifact "Value Mapping for SAP Cloud for Customer and SAP Marketing Integration" as stated in our documentation: Setting Up SAP Marketing Cloud Integration with SAP Cloud for Customer (1J9).

Keywords

C4C MARKETING CPI ROLES RELATIONSHIP ROUTER NOT EMPTY , KBA , CEC-MKT-INT-CSL , SAP Marketing Integration with Cloud Sales , LOD-CRM-INT-YMT , Integration of C4C with Marketing , Problem

Product

SAP S/4HANA Cloud 2202