SAP Knowledge Base Article - Public

3198889 - Product Search on Cloud for Customer Showing Not Related Data

Symptom

You are searching for Products on field "Products" on C4C App or on Desktop Version, however it  is showing not related items or none at all.

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Go to Sales Orders work center.
  2. Select new order button.
  3. Select any customer on Account field.
  4. Select the add product option.
  5. select the product search field.
  6. Enter a 3-digit product code, example 100
  7. You will see a list of products but only one with code 100 that is being searched for.
  8. Several other results without 100 entry.

Cause

The Search field searches via various data, not only Code or Description. Other fields, which are search-relevant, are: Remote Object ID, Model Catalog, GTIN, Descriptions, Remote System IDs.

As an example, the found product ID ABC (ABC is a Product on your system) has a GTIN value 100 (100 is a value of GTIN field inside a Product on your system) assigned.

Resolution

If you need to search more precisely, the advanced search has to be used.

Keywords

Product Search, Products C4C, Search Field. , KBA , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions