SAP Knowledge Base Article - Public

3198947 - Unable to Activate DocuSign Connection for OAuth 2.0 - Onboarding 1.0

Symptom

When trying to enable the new DocuSign OAuth2.0, the system says that "The Account ID and API user combination you entered was not recognized" . 

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Onboarding 1.0

Cause

Incorrect “API User ID” and/or “Account ID”

Resolution

If the screenshot is not visible to you, please find the same steps and screenshots from attached PDF file.

  • For New customer:
  1. Need to set “Integration Type”
  2. Click button “Connection to DocuSign”
  3. Login to DocuSign site in the additional popup
  4. Click “Allow Access”

  5. Click the button “Ok” in the following popup with message "You consented to activate DocuSign for SAP SuccessFactors Onboarding. Complete the DocuSign eSignature Activation Option to activate DocuSign for SAP SuccessFactors Onboarding"

    1. Go to DocuSign Site, “Settings”/”Integrations”/ “Apps and Keys”
    2. Copy “User ID” and “API Account ID”
    3. Paste “API Account ID” to “Account ID”and “User Id” to “API User Id” in the feature page
    4. Set another properties based on necessity
    5. Click the button “Activate”

    • For Existing customers
    1. Click the button “Update DocuSign Authentication”
    2. Login to DocuSign site in the additional popup
    3. Click “Allow Access”
    4. The following popup will appear and “API User ID” and “Account ID” will be filled in automatically.

    Keywords

    OAuth, DocuSign, authentication, sf, success factors, ONB, OBD, on boarding , KBA , LOD-SF-OBD-DSN , DocuSign , Problem

    Product

    SAP SuccessFactors Onboarding all versions

    Attachments

    steps&screenshots.pdf