SAP Knowledge Base Article - Public

3199219 - How to cancel an Inbound Delivery when all its item have Zero Quantity

Symptom

You have created an Inbound Delivery XYZ (where XYZ is the ID of the Inbound Delivery) recording that none of the products were received. Now you are trying to cancel the involved Purchase Order, but you are receiving an error saying you have open Deliveries, even with all items already being set to zero.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Purchase Requests and Orders work center.
  2. Go to Purchase Orders view.
  3. Select the desired document.
  4. Click on Cancel.
  5. Receive the error "Cancellation not allowed. Check open delivery documents".

Cause

The error is triggered as the Inbound Delivery is still a valid document, even if their items have zero quantity. The document must still be reverted.

Resolution

To cancel an Inbound Delivery with no quantities, the following steps must be performed:

  1. Go to Inbound Logistics work center.
  2. Go to Inbound Deliveries view.
  3. Find the Inbound Delivery XYZ.
  4. Access the Document Flow.
  5. Open the Warehouse Order.
  6. Perform an Adjustment Confirmation for the same, adding 1 unit for all items.
  7. Now, perform a new Adjustment Confirmation, removing 1 unit for all items.
  8. After executing these steps, the documents will be available for cancellation.

Keywords

KBA , AP-IP-INV , Inventory , How To

Product

SAP Business ByDesign all versions