SAP Knowledge Base Article - Public

3199399 - Unable to run GET call in API_MANAGE_WORKFORCE_TIMESHEET in Postman

Symptom

When sending a GET call to API API_MANAGE_WORKFORCE_TIMESHEET you are getting error SYSTEM_NO_ROLL.

Environment

SAP S/4HANA Cloud.

Reproducing the Issue

Send GET call as shown below adapted to your system:

/sap/opu/odata/sap/API_MANAGE_WORKFORCE_TIMESHEET/TimeSheetEntryCollection

Cause

Call is not filtered and is picking up all results, as the result is too big to be returned in a single call the error SYSTEM_NO_ROLL is raised.

Resolution

Filter your call in order to narrow down the results, one example is below: 

/sap/opu/odata/sap/API_MANAGE_WORKFORCE_TIMESHEET/TimeSheetEntryCollection(PersonWorkAgreementExternalID='',CompanyCode='',TimeSheetRecord='')

Keywords

Time Sheet, employee, error, dump , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions