Symptom
E-mail sent from C4C - Wrong e-mail determination after share view.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Analysis work center
- Access the Reports work center view
- Open any report
- Change report view to a custom view
- Click the More Actions (...) button, then select Share View
- Enter the relevant data and send the e-mail
Check the Sender e-mail address; it is not noreply@company.tld (the system's default sender address) but 1.name.2.name@company.tld (users e-mail address)
Cause
Sender E-mail Scenarios:
- If you share a view/selection with user who HAS admin access, then the default e-mail address which is maintained in the system takes the precedence over the individual user e-mail address.
- If you share a view/selection with user who DO NOT have admin access, then the e-mail address maintained by the user will be considered.
- If you share a view/selection with user who DO NOT have admin access & HAVE NOT maintained any e-mail address, then default address maintained in the system will be considered.
Resolution
This is expected system behaviour as you want to see which user sent you the view you got shared.
Keywords
email, e-mail, share view, wrong, C4C , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions