SAP Knowledge Base Article - Public

3199901 - Exclude Search for E-mail Channel Field in Unassociated E-mails

Symptom

You noticed the exclude search in advanced filter is not working as expected for the Channel Field in the unassociated e-mails.

Environment

SAP cloud for Customer

Reproducing the Issue

  1. Navigate to Service Work Center.
  2. Go to Unassociated E-mails Work Center View.
  3. Click Advanced Filter. 
  4. Click "+>" in the Channel Field.
  5. Go to Exclude -> Value.
  6. Select channel ABC (where ABC is the name of the channel).
  7. Click Ok and Go.
  8. See the results.

Cause

The exclude functionality searches against all parties assigned to an e-mail, so excluding directly based on channel may not be working as there can be multiple parties for the e-mail.

Resolution

The field "To" can be used for exclusion of the e-mail address. However, as there is a string comparison, if multiple e-mails are present in "To" string, the value does not match with the filter parameter.

Keywords

Exclude; To; E-mail channel; Channel; Field; Include; Unassociated; E-mails; Unassociated E-mails; , KBA , LOD-CRM-SC-EML , Email , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions