Symptom
You noticed the exclude search in advanced filter is not working as expected for the Channel Field in the unassociated e-mails.
Environment
SAP cloud for Customer
Reproducing the Issue
- Navigate to Service Work Center.
- Go to Unassociated E-mails Work Center View.
- Click Advanced Filter.
- Click "+>" in the Channel Field.
- Go to Exclude -> Value.
- Select channel ABC (where ABC is the name of the channel).
- Click Ok and Go.
- See the results.
Cause
The exclude functionality searches against all parties assigned to an e-mail, so excluding directly based on channel may not be working as there can be multiple parties for the e-mail.
Resolution
The field "To" can be used for exclusion of the e-mail address. However, as there is a string comparison, if multiple e-mails are present in "To" string, the value does not match with the filter parameter.
Keywords
Exclude; To; E-mail channel; Channel; Field; Include; Unassociated; E-mails; Unassociated E-mails; , KBA , LOD-CRM-SC-EML , Email , How To