SAP Knowledge Base Article - Public

3201045 - Exclude Party Role Does Not Work on Account Advanced Search

Symptom

You excluded a party role ABC (ABC represents party role ID) from search results in Account OWL. However, some accounts with party role ABC are still being shown in the results.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customers workcenter, Accounts view. 
  2. Click on the Advanced Search icon, then "+" in the Party Role field.  
  3. Choose to exclude party role ABC and "OK".
  4. Click to show the results and see that there're some accounts with party role ABC are still being shown in the results. 

Cause

The accounts that are being shown at the results have more than one party role assigned to it.

Parameter 'Party Role" is an attribute of the related table of involved parties (Account Team). You usually have several parties with different party roles assigned to an Account, therefore, a search with 'exclude' for party does not deliver meaningful results.

Resolution

 This is the expected system behavior.

See Also

 2877856 - Advanced Search Filter In Opportunities Is Not Working

 2756581 - Account Advance Search with Employee Exclude Query Option

Keywords

Account; Advanced Search; Exclude; Party Role; , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer core applications 2202