SAP Knowledge Base Article - Public

3201102 - Error Displayed When Trying to Replicate Employee: Time Profile Start Date Cannot Be Changed Due to Existing Employee Time Before DD.MM.YYYY

Symptom

When trying to replicate an employee, the system displays the following error message:

"Time Profile start date cannot be changed, employee time exists before DD.MM.YYYY"

Environment

SAP Business ByDesign

Cause

This issue might be occurring because the calendar currently assigned to the employee in SAP Business ByDesign is "X". However, the holiday calendar specified in the replication request from SAP SuccessFactors Employee Central is "Y".

Resolution

As per the documentation and the new holiday calendar support from SAP SuccessFactors Employee Central to SAP Business ByDesign, please refer to the following SAP Help document:

What's New in Human Resources

The provided link will help understand why the replication request currently has the holiday calendar "Y" instead of "X" for the employee.

Code mapping needs to be performed in SAP SuccessFactors to ensure that SAP Business ByDesign interprets the correct holiday calendars received from SuccessFactors Employee Central.

It is kindly suggested to map the correct external code in SAP SuccessFactors Employee Central for the holiday calendar and then query this employee to ensure that the correct holiday calendars are received in the replication request.

Keywords

Replication, Employee, Start Date, Time Profile , KBA , SRD-HR-TLM , Time and Labour Management , How To

Product

SAP Business ByDesign all versions