SAP Knowledge Base Article - Public

3201562 - Chat Interactions are Duplicated for the Same External ID

Symptom

 You have noticed that the Chat Interactions are duplicated for the same External ID.

Environment

SAP Cloud for Customer

Cause

You are passing incorrect parameters.

Resolution

When passing parameters for chat, please consider the following:

  • Only use the parameters Type and EventType. The parameter "Event" is not required for chat creations.
  • If you use Type=Chat and EventType=Inbound it will always create a new chat.
  • If your intention is to update an existing chat with transcript, then you can use Type=CHAT, EventType=UPDATEACTIVITY, Action=END and use the same external Reference as you provided for EventType=INBOUND, this will result in the system updating the already existing chat.

Keywords

Placeholder; Ticket; CTI; Provider; , KBA , LOD-CRM-LA , Live Activity , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions