SAP Knowledge Base Article - Public

3202522 - Odata Service Standard Field "ChangedByCustomerIndicator" for Service Request BO is not Found in the Odata Service Explorer

Symptom

 Image/Data is from SAP internal systems, sample data, or demo systems.  Any resemblance to real data is purely coincidental.

  • Business would like to use the Business Object (BO) property "Assigned to" from tickets
  • When trying to create a custom OData Service, the administrator is unable to find the "ChangedByCustomerIndicator" property under the Service Request BO

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to the Administrator Work Center.
  2. Go to OData Service Explorer Work Center View.
  3. Select the filter Custom OData Service.
  4. Add a new entry or edit the current one.
  5. Expand the Root Node for the BO Service Request.
  6. Cannot find the field "Changed By Customer Indicator"

Cause

Changed By Customer Indicator property is not stored in Root Node of Service Request BO. It is stored under ServiceTerms Node.

Resolution

  1. Navigate to the Administrator Work Center.
  2. Go to the OData Service Explorer Work Center View
  3. Open the custom OData Service created and edit or create a new one.
  4. Under Root, navigate to "ServiceTerms" -> ChangedByCustomerIndicator
  5. Select ChangedByCustomerIndicator, as seen from the below example screenshot:
    ServiceTerms_Indicator.png

See Also

  • KBA 2713787 - How to Add AccountName to Custom OData Service Based on Opportunity Collection
  • KBA 2842090 - Frequently Asked Questions on Custom OData Services
  • KBA 3152111 - Odata Service Standard field "Assignedto" for Service Request BO is not found in the Odata Service Explorer 

Keywords

ChangedByCustomerIndicator;  ServiceTerms; OData; Custom OData; BO; ServiceRequest , KBA , LOD-CRM-SRP-API , Ticket API & Odata , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions