Symptom
Image/Data is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
- Business would like to use the Business Object (BO) property "Assigned to" from tickets
- When trying to create a custom OData Service, the administrator is unable to find the "ChangedByCustomerIndicator" property under the Service Request BO
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to the Administrator Work Center.
- Go to OData Service Explorer Work Center View.
- Select the filter Custom OData Service.
- Add a new entry or edit the current one.
- Expand the Root Node for the BO Service Request.
- Cannot find the field "Changed By Customer Indicator"
Cause
Changed By Customer Indicator property is not stored in Root Node of Service Request BO. It is stored under ServiceTerms Node.
Resolution
- Navigate to the Administrator Work Center.
- Go to the OData Service Explorer Work Center View
- Open the custom OData Service created and edit or create a new one.
- Under Root, navigate to "ServiceTerms" -> ChangedByCustomerIndicator
- Select ChangedByCustomerIndicator, as seen from the below example screenshot:
See Also
Keywords
ChangedByCustomerIndicator; ServiceTerms; OData; Custom OData; BO; ServiceRequest , KBA , LOD-CRM-SRP-API , Ticket API & Odata , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions