SAP Knowledge Base Article - Public

3202577 - Sales Order Confirmation with E-mail Not Maintained in Account Master Data

Symptom

You are creating a Sales Order with an Account which does not have an e-mail address maintained, you have added the e-mail address to the Account/Bill-To Additional Details and when clicking Sales Order Confirmation the output is not being sent to the address maintained.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Go to the Sales Orders view.
  3. Search for the Sales Order ID ABC (ABC represents the ID of the Sales Order).
  4. Click Edit.
  5. Click on View All button.
  6. Select the Additional Details under the Account.
  7. In the General tab, enter the desired e-mail.
  8. Click Send Order Confirmation to Account.
  9. Open the document again.
  10. Navigate to the Output History tab.
  11. The confirmation is not sent to the expected e-mail address. 

Cause

As per the Help Center document "Process-Integrated Output Settings" in order to be able to send an e-mail to the expected e-mail address, you need to maintain it in the Collaboration tab for the Account Master Data or in the Sales Order view, following the steps below:

  1. Go to the Sales Orders work center.
  2. Go to the Sales Orders view.
  3. Search for the Sales Order ID ABC (ABC represents the ID of the Sales Order).
  4. Click Edit.
  5. Click on View All button.
  6. On the top of the page, in the right side, click on You Can Also.
  7. Select Edit Output Settings.

Resolution

This is the system expected behavior.

As a work around, you can pass or update the Contacts e-mail but make sure that under the Account master data, you have maintained the E-mail as the Output Channel.

  1. Go Account Management work center.
  2. Select the Accounts view.
  3. Search for the Account XYZ (XYZ represents the ID of the Account).
  4. Click Edit.
  5. Navigate to the Communications tab.
  6. Select the Collaborations subtab.
  7. Select Sales Order Confirmation.
  8. Under Output Channel Settings, enter E-mail as the output channel.
  1. Go to the Sales Orders work center.
  2. Go to the Sales Orders view.
  3. Search for the Sales Order ID.
  4. Click Edit.
  5. Click on View All button.
  6. Navigate to the Involved Parties tab.
  7. Select the Account.
  8. Scroll down to the Related Contacts subtab.
  9. Here you can maintained a contact and the e-mail address. 

Please note that you can update the Related Contacts information via PDI or Webservice.

 

See Also

Process-Integrated Output Settings

Keywords

Sales Order Confirmation, E-mail,  Sales Order,  Not Maintained, Account, Master Data, Output Channel , KBA , AP-SLO-SO , Sales Order , How To

Product

SAP Business ByDesign all versions