Symptom
You are creating a Sales Order with an Account which does not have an e-mail address maintained, you have added the e-mail address to the Account/Bill-To Additional Details and when clicking Sales Order Confirmation the output is not being sent to the address maintained.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Search for the Sales Order ID ABC (ABC represents the ID of the Sales Order).
- Click Edit.
- Click on View All button.
- Select the Additional Details under the Account.
- In the General tab, enter the desired e-mail.
- Click Send Order Confirmation to Account.
- Open the document again.
- Navigate to the Output History tab.
- The confirmation is not sent to the expected e-mail address.
Cause
As per the Help Center document "Process-Integrated Output Settings" in order to be able to send an e-mail to the expected e-mail address, you need to maintain it in the Collaboration tab for the Account Master Data or in the Sales Order view, following the steps below:
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Search for the Sales Order ID ABC (ABC represents the ID of the Sales Order).
- Click Edit.
- Click on View All button.
- On the top of the page, in the right side, click on You Can Also.
- Select Edit Output Settings.
Resolution
This is the system expected behavior.
As a work around, you can pass or update the Contacts e-mail but make sure that under the Account master data, you have maintained the E-mail as the Output Channel.
- Go Account Management work center.
- Select the Accounts view.
- Search for the Account XYZ (XYZ represents the ID of the Account).
- Click Edit.
- Navigate to the Communications tab.
- Select the Collaborations subtab.
- Select Sales Order Confirmation.
- Under Output Channel Settings, enter E-mail as the output channel.
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Search for the Sales Order ID.
- Click Edit.
- Click on View All button.
- Navigate to the Involved Parties tab.
- Select the Account.
- Scroll down to the Related Contacts subtab.
- Here you can maintained a contact and the e-mail address.
Please note that you can update the Related Contacts information via PDI or Webservice.
See Also
Keywords
Sales Order Confirmation, E-mail, Sales Order, Not Maintained, Account, Master Data, Output Channel , KBA , AP-SLO-SO , Sales Order , How To