Symptom
You see the error 404 pop-up in your Guided Selling views.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work centre
- Go to the Guided Selling view
Several issues occur:
- 404 errors popping up:
- A 404 error pops up on GS the OWL
- A 404 pops-up when you open any Opp in GS
- You can x-out of the error (close the error banner), but it will pop up again if you navigate to a new opportunity within GS, or go back to the GS OWL, any view switch seems to be calling the 404 error.
- Missing Opportunities in Kanban view.
- Missing Sales Phase bar
Cause
If a Sales Cycle does not have any Sales Phases associated with it, this will cause an error/ inconsistencies.
The Kanban view has lanes which are representative of Sales Phases within the chosen Sales Cycles, and in this case - if there is no Sales Phase associated - that view would be blank - that is Correct system behaviour.
The Table view shows you opportunities which have an assignment to this Sales Cycles.
On opening the opportunity, we try to create a progress bar - showing where the opportunity lies and what will be its path - in direct reference of its Sales Phase movement.
Again, if there is no sales Phases for a particular Sales Cycle - it will not show that tracker.
Resolution
- Regarding the error message being a generic 404: will enhance our code to show more meaningful error messages in the future.
- Please maintain correct Sales Phases in your configuration of the Sales Cycles in C4C to have this issue resolved.
Go to Business Configuration > Implementation Projects > Select your project and navigate to Open Activity List > Fine-Tune > Sales Cycles and Phases > here, define your sales processes.
See Also
Keywords
KBA , LOD-CRM-SBS-GS , Guided Selling and Playbook , Problem