SAP Knowledge Base Article - Public

3203462 - Missing specific Delivery Method in user Library search

Symptom

A specific Delivery Method is missing under Refine By options in Library search.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Login to My Learning
  2. Click "Browse all courses" from Find Learning tile
  3. In Refine By > click Delivery Method to see Delivery Methods available
    *in Learning Administration there are more options than the user can see

Cause

The Delivery Methods will be visible in case the system finds the below conditions:

  • In Learning Administration > System Administration > Configuration > System Configuration > LIBRARY config file, check if catalogSearchFilters[DeliveryMethod]=true
  • The Delivery Method needs to be added in at least one active item included into any Library that the user has access to

Resolution

Add the Delivery Method to any item that is currently added to a Library which user affected has access to and check the behavior.

In case the field Delivery Method is not available in the Item Details field, please add it by following the steps below:

  1. In Learning Administration > System Administration > Configuration
  2. Click 'Entity Configuration'
  3. Choose the option "Item" in the drop down
  4. Find the Field Name "Delivery Method"
  5. Select the checkbox "Display"
  6. Save your changes

Keywords

lms, delivery method, library, catalog, not show, not appear , KBA , LOD-SF-LMS-CAT , Catalog , Problem

Product

SAP SuccessFactors Learning all versions