Symptom
You are facing the error message "ID mapping for external value 1234 of Organisational Centre ID missing" when replicating Business Partners from external system with DeliveringPlantID available in the payload.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Select query All.
- Search for failing message ID.
Error: ID mapping for external value 1324 of Organisational Centre ID missing (where 1234 is the ID of Org Unit maintained in C4C).
Cause
In the inbound message there was one additional field missing <DeliveringPlanIDTypeCode>27</DeliveringPlanIDTypeCode>.
In many cases an additional TypeCode field is not necessary when the field has an explicit name. As you are sending DeliveringPlantID, the expectation is that C4C knows to look up the Plant ID Mapping. In this case, C4C needs the DeliveringPlantIDTypeCode field with value 27 to look it up in the right ID Mapping table. With this field missing, it apparently tries to determine a "normal" Sales Org. ID and then the error message is raised, because Sales Organization has no Plant flag.
You usually need that when you have a list of IDs where the TypeCode tells the system what kind of ID it needs to look up. For instance, it is determined for Party Role codes, such as for the buyer we usually have a separate field BuyerParty. For other customer specific parties we need to give a PartyID and a TypeCode to specify what kind of party.
Resolution
Please check the mapping in the middleware and maintain the DeliveringPlanIDTypeCode defined.
See Also
Keywords
ID mapping for external value 1234 of Organisational Centre ID missing; ID mapping; Organisational Centre , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To