Symptom
During the processing of the EDI message for the inbound sales order, an error is displayed at the Message Dashboard app: A more recent version of this EDI message has already been processed.
Environment
SAP S/4HANA Cloud
Cause
The system uses the <CreationDateTime> field under <MessageHeader> to check whether this message has already been processed.
Resolution
You need to update the <CreationDateTime> field under <MessageHeader> at the Payload to a larger value each time the request is sent.
See Also
Keywords
OrderRequest_In, B2B, sales order, EDI, SOAP API, SAP_COM_0223, 2EL, /SDEDI, EDI_SD_ORDR_RECIPIENT, Message Dashboard, EDI_SD_ORDR_PROCESSING , KBA , SD-SLS-EDI , S/4HANA: Sales EDI Messages , SD-SLS , Sales , SD-SLS-EDI-2CL , S/4HANA: Sales EDI Messages (Public Cloud) , SD-SLS-API , API , How To