SAP Knowledge Base Article - Public

3204112 - Text in description field within a ticket gets deleted once an inbound Live Activity interaction arrives

Symptom

  • You have a CTI integration using Live Activity 
  • User noticed that when working on a ticket, there is data loss when a new inbound phone call, chat, sms etc, arrives
  • After the inbound interaction is done, when navigating back to the ticket, the previously entered information is lost 

    Image/Data is from SAP internal systems, sample data, or demo systems.  Any resemblance to real data is purely coincidental.

Environment

  • SAP Cloud for Service
  • SAP Cloud for Sales
  • SAP Cloud for Customer
  • Sinch Contact Pro
  • SAP Contact Center
  • SAP Local Adapter 

Reproducing the Issue

  1. Create a new ticket
  2. Add some text into the description field
  3. Trigger a new inbound interaction
  4. The system automatically navigates to the Live Activity view (this needs to be configured to auto-navigate *

Cause

  • Currently (as of the authoring of this KBA) there is no "Auto-Save" draft feature available
  • Round trip in the UI causes potential data loss
    • This has the same effect as reloading the UI, in which case the unsaved data would be lost
    • Switching from one tab to another does not have the same effect as a round-trip/reload, since facets are built on Iframe and the content is not reloaded but rather hidden from view.

Resolution

  1. Go to "Administrator" > "Service and Social" > "Live Activity Configuration" 
  2. Disable the "Open Details Automatically for Incoming Communication"
    OpenDetailsAutoIncominComms.png
  3. Save the changes, and reload the UI
  4. Test

Please note:

  • Enabling TinyMCE would not work for this case, since tickets use the default built-in editor (RTE Editor) which cannot be changed
  • If you feel the above requirement should be included in upcoming releases, then please consider submitting a request via the SAP Customer Influence Program.
  • Please refer to KBA 2531650, for further details.

See Also

 3202053 - Incoming CTI interactions causes email/notes unsaved draft

Keywords

Auto-save, decription, not saved, data loss, tickets, live activity,  description value disappears when incoming call is connected, Subject, roundtrip, CTI, clear, deleted , KBA , c4c , deleted , description , dissapears , data loss , cloud for service , erased , LOD-CRM-LA , Live Activity , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications 2202