Symptom
Getting below error when customer try to perform upsert operation for any background entity for inactive user.
"com.successfactors.edu.service.UserHasNoPermissionException"
Environment
- SAP SuccessFactors HXM suite
- Integrations
- OData API Framework
- Integrations
Reproducing the Issue
1. Prepare the payload.
2. Run through postman application.
3. Getting below error.
"com.successfactors.edu.service.UserHasNoPermissionException"
Cause
This Is expected behaviour,
On Employee Profile side, all the Background_* entities have the logic on permission check for upsert.
The logic will be: When target user is an onboarding user, inactive users and to be hired users are not supported being upserted.
Resolution
As the logic explain in Cause.
On Employee Profile side, all the Background_* entities have the logic on permission check for upsert operation. that means if user is in inactive state they you will receive no permission error message
To perform the upsert operation for background_* entity user must be in active state And for onboarding user, inactive users and to be hired users are not supported being upserted.
Keywords
background_*, Odata, Successfactors, API, Background Entity, upsert , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT-API , API & Adhoc API Framework , Problem
Product
Attachments
Pasted image.png |