SAP Knowledge Base Article - Public

3206211 - No Automatic Warranty Assignment in Registered Product Issued Against Project Stock Order

Symptom

You have scoped the question "Do you want the solution to automatically assign warranty for registered products sold during the outbound delivery process?" in Business Configuration. And when you do a Post Goods Issue against a Sales Order, the Warranty Assignment is working as expected. However, if the Outbound Delivery is created against a Project Stock Order, the Warranty is not automatically assigned to the Registered Product.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Create a Pre-Delivery Project Stock Order and release same to Logistics Execution.
  2. Go to the Delivery Proposals view of the Outbound Logistics work center.
  3. Find and select the relevant Delivery Proposal.
  4. Click Post Goods Issue and enter all necessary details including the Serial Numbers.
  5. Click Release and note down the Outbound Delivery ID you just created.
  6. Go to the Outbound Deliveries view.
  7. Find and select the relevant Outbound Delivery.
  8. Click Edit and go to the Line Items tab.
  9. Select the row with the relevant Product ID.
  10. Go to the Serial Numbers sub-tab and open the desired Serial Number via the hyperlink.
  11. You can see in the Registered Product Overview windows that opens under the Warranty Assignment section that there is no Warranty assigned to the Registered Product.

Cause

You have scoped the question correctly in Business Configuration. However, the Warranty and Account Assignment of Registered Products are designed to happen only in Over the Counter Sales, Third Party and Standard Outbound Deliveries. In a Project Stock Orders, the assumption is that the delivered products remain property of the executing company and no assignment takes place.

Resolution

This is the intended system behavior.

As a workaround, you can manually assign the Account and Warranty information in the Registered Product Master Data. You can also contact your implementation partner to create a PDI solution to achieve an automatic assignment.

See Also

 2416594 - Warranty not assigned automatically in Outbound Logistics

Keywords

Project Stock Order, Warranty, Assignment, Service Entitlement , KBA , AP-IBA-IPO , Installation Point , AP-ODP , Outbound Delivery Processing , Problem

Product

SAP Business ByDesign all versions