SAP Knowledge Base Article - Public

3206632 - Check in Customer Invoice Request does not Pick Up on the Missing Value of a Mandatory Extension Field

Symptom

You created an extension field in the Customer Invoice Request and set this to mandatory.

When clicking on the Check button the system does not show any error messages eventhough the mandatory field has no value.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Customer Invoicing work center. 
  2. Select the Invoice Requests view.
  3. Select Manual Invoice Request XYZ (XYZ represents the invoice request ID). 
  4. Click on the Check button. 
  5. No error occurs eventhough the mandatory field ABC has no value (ABC represents the extension field).  

Cause

Setting a field to be mandatory creates a UI validation. This is handled in the UI itself. This is why the "Check" action does not pick this up.

Resolution

This is the current system behavior.

Keywords

Check; Invoice Request; Extension Field; Mandatory; UI; , KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign 2022